Resultados 1 al 4 de 4

Tema: Errores en la V10.1

  1. #1
      Forero
    Avatar de Dasije

    Registrado
    noviembre de 2015
    Mensajes
    182
    Ciudad
    Jerez De La Frontera (cádiz)

    Agradecimientos
     
    Recibidos
    79
    Enviados
    1

    Citaciones y menciones
     
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Poder de Reputación
    14

    Predeterminado Errores en la V10.1

    Hola buenas.

    Enumero los errores que me he encontrado de pasar de la versión 9 a la 10.1, y que antes no ocurría:

    • Error de compilación, EXIT PROGRAM dentro de una condición después de un CALL
    • No funciona calcular el largo de una variable alfanúmerica dentro de un COMPUTE de manera manual
    • Error de compilación, no puedes lanzar un INVOKE después de un END-COMPUTE
    • En vez en cuando, por razones desconocidas, desaparecen la vista de los controles dentro de un formulario en modo desarrollo
    • No controla el evento LostFocus cuando está programado cuando solo lo haga cuando haya algo escrito en el campo. y se dispara sin tomar en cuenta la condición.


    Habrá más sin descubrir, poco a poco.@Kuk, @Nitzer, @JRBonafonte,

    0 Not allowed!
    Empresa de desarrollo de aplicaciones en COBOL.

    DASIJE INFORMATICA, S.L.
    C/ TOMAS BRETON 20
    11406 JEREZ DE LA FRONTERA
    CADIZ

    Teléfono : 956 11 21 11
    Web: http://www.dasije.es / DASIJE INFORMATICA
    E-m@il: clientes(@)dasije.es

  2. #2
      Administrador
    Avatar de Kuk

    Registrado
    enero de 2015
    Edad
    37
    Mensajes
    2,011
    Ciudad
    Madrid

    Agradecimientos
     
    Recibidos
    862
    Enviados
    720

    Citaciones y menciones
     
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    5 Post(s)
    Poder de Reputación
    10

    Predeterminado

    Yo también he notado alguna cosa, sobre todo el problema del "LostFocus" pero pensé que eran paranoias mías...
    Lo que he visto también es que algún que otro OCX no funciona, por ejemplo el TabControl de Codejock que funcionaba perfectamente en la versión 9.

    0 Not allowed!

    ¿Te han ayudado? NO TE OLVIDES de darle al botón
    ¿Quieres dirigirte a alguien en tu post? Notifícale con una mención, tienes 2 opciones:
    1. Haciendo clic en el icono al lado de su nick
    2. Haciendo clic en el editor al botón y escribiendo su nick.

  3. #3
      Super Moderador
    Avatar de Josber

    Registrado
    febrero de 2015
    Mensajes
    641
    Ciudad
    Alicante

    Agradecimientos
     
    Recibidos
    338
    Enviados
    298

    Citaciones y menciones
     
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)
    Poder de Reputación
    35
    Activista del Foro / Point Value: 0 Agradecimientos / Point Value: 0

    Predeterminado

    Cita Iniciado por Dasije Ver Mensaje
    En vez en cuando, por razones desconocidas, desaparecen la vista de los controles dentro de un formulario en modo desarrollo
    Eso lo hace también la versió 9, o pr lo menos a mí me lo ha hecho varias veces, sobre todo cuando copias un Form entero en otro, al Form de origen, le desaparecen los controles, me guastaría saber si alguien ha podido bajarse la versión 11 y probarla ... para saber si esos errores están corregidos, entre otras cosas.

    Un saludo

    0 Not allowed!

  4. #4
      Administrador
    Avatar de Kuk

    Registrado
    enero de 2015
    Edad
    37
    Mensajes
    2,011
    Ciudad
    Madrid

    Agradecimientos
     
    Recibidos
    862
    Enviados
    720

    Citaciones y menciones
     
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    5 Post(s)
    Poder de Reputación
    10

    Predeterminado

    Amigos, yo no sé si volver a la versión 9... Me parece más estable, y las versiones posteriores, no traen casi nada, salvo alguna pequeña tontería de compatibilidad.

    A lo mejor lo bueno sería usar la versión 9 y distribuir con los Run-Times de versiones más nuevas? :rolleyes:

    0 Not allowed!

    ¿Te han ayudado? NO TE OLVIDES de darle al botón
    ¿Quieres dirigirte a alguien en tu post? Notifícale con una mención, tienes 2 opciones:
    1. Haciendo clic en el icono al lado de su nick
    2. Haciendo clic en el editor al botón y escribiendo su nick.

Información de Tema

Usuarios Viendo este Tema

Actualmente hay 1 usuarios viendo este tema. (0 miembros y 1 visitantes)

Temas Similares

  1. [Sintaxis] Ayuda a principiante con unos errores
    Por Hipromark en el foro COBOL - General
    Respuestas: 3
    Último Mensaje: 04.05.2018, 19:26
  2. [Información] Códigos de errores de RM/Cobol
    Por jmeza en el foro RM/COBOL
    Respuestas: 1
    Último Mensaje: 06.05.2017, 16:56
  3. [Compilador] Diferencias PowerCOBOL v9.0 y v10.1
    Por Kuk en el foro PowerCOBOL (ActiveX, v4 - v11)
    Respuestas: 5
    Último Mensaje: 20.04.2015, 10:23
  4. [Componente] Run-Times y Merge-Modules v10.0
    Por Rapinto en el foro PowerCOBOL (ActiveX, v4 - v11)
    Respuestas: 0
    Último Mensaje: 08.02.2015, 15:57

User Tag List

Permisos de Publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •